Description
Error code: 46048
Error text: Failed to get metadata for key $type. Error code:$num
Where $type is the type of metadata that is missing such as a matchingString or a offendingAttachment. $num is the error number associated with this failure.
Affected module: brightmail_client
Symantec Brightmail Gateway 9.0 and later versions
Symptoms:
If $type is offendingAttachment, a message that violated a compliance policy with an action of Strip matching attachments does not remove the matching attachments.
If the $type is matchingString, a message that violated a compliance policy with an action of Create an incident (either an informational incident or a quarantine incident) does not have the expected Policy Match Text. However, Message audit logs have this information.
Cause:
This error can occur if the Brightmail Engine or bmserver suddenly stops while the mail is still being processed.
Resolution:
This error should rarely occur; if it is a one-time event, it can be safely ignored. If the error occurs repeatedly, contact Symantec customer support for assistance.
Log sample:
The following is a sample of the error message as it appeared in the bmclient_log:
<date>T<time> (ERROR:4998.2993609616): [46048] Failed to get metadata for key matchingString. Error code:1.
Terms of use for this information are found in Legal Notices.