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文書番号: 949377 - 最終更新日: 2009年6月30日 - リビジョン: 5.0

Windows XP Service Pack をインストールするときに、エラー メッセージ "アクセスが拒否されました" または "Service Pack のインストールは完了しませんでした" が表示される

目次

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現象

Windows XP Service Pack 2 (SP2) または Service Pack 3 (SP3) のインストール時に、以下のいずれかのエラー メッセージが表示される場合があります。
Service Pack 3 セットアップ エラー。アクセスが拒否されました。
Service Pack 3 セットアップ エラー。Service Pack のインストールは完了しませんでした。
または、Svcpack.log ファイルに、以下のエラー メッセージが記録される場合があります。
DoRegistryUpdates failed

原因

1 つ以上のレジストリ キーのアクセス許可が、そのレジストリ キーを更新できないように制限されている場合に、これらのエラー メッセージが表示されることがあります。特定のプログラムによって、レジストリのシステム アクセス制御リスト (SACL) が変更され、管理者アカウントでそれらを変更できなくなる場合があります。Service Pack のインストーラーは、管理者アカウント (ユーザー) で実行されるので、制限されたレジストリ キーにアクセスできません。レジストリ キーが他のプログラムによって制限されているために、Windows XP Service Pack でレジストリ キーを更新できない場合、Service Pack のインストールは失敗します。

レジストリの更新が正常に行われなかったことを確認するには、「詳細」を参照してください。

解決方法

この問題を解決するには、次のトラブルシューティングの方法を示されている順に従って実行してください。この方法は中級レベルから上級レベルのコンピューター ユーザーを対象にしています。

: この方法を実行するには、コンピューター管理者であるユーザー アカウントで Windows にログオンする必要があります。個人のコンピューターを使用している場合は、ほとんどの場合、既に管理者アカウントでログオンしています。職場のネットワークの一部であるコンピューターを使用している場合は、システム管理者への問い合わせが必要になる可能性があります。コンピューター管理者であるユーザー アカウントで Windows にログオンしているかどうかを確認するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/gp/admin (http://support.microsoft.com/gp/admin)

方法 1: コンピューターを再起動し、Microsoft ダウンロード センターから Windows XP SP3 をダウンロードしてインストールする

ファイルがロックされた状態でプログラムが実行されている場合、コンピューターを再起動することによってファイルのロックが解除されることがあります。ファイルのロック解除を試してみるには、すべてのプログラムを終了し、コンピューターを再起動します。次に、Service Pack をダウンロードしてインストールしてみます。

前回、Windows Update を通じて Windows XP SP3 をインストールしようとして失敗した場合は、Microsoft ダウンロード センターから Windows XP SP3 のフル ダウンロード パッケージをダウンロードします。Service Pack をダウンロードしてから、インストールします。 Windows XP Service Pack 3 をダウンロードする方法の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
322389  (http://support.microsoft.com/kb/322389/ ) 最新の Windows XP Service Pack を入手する方法
この方法でエラー メッセージが解決され、Windows XP SP3 が正しくインストールされた場合、作業は完了です。

Windows XP で既定のセキュリティ設定を復元する方法の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
313222  (http://support.microsoft.com/kb/313222/ ) セキュリティ設定を既定の設定に戻す方法


この方法で問題が解決しない場合は、方法 2 に進みます。

方法 2: コンピューターを再起動し、実行されているウイルス対策プログラムおよびスパイウェア対策プログラムをすべて終了するか、無効にする

警告: この資料に記載された回避策を適用すると、悪意のあるユーザーまたはウイルスなどの悪質なソフトウェアによる攻撃をコンピューターまたはネットワークが受けやすくなる場合があります。この資料の情報は、記載されている回避策をユーザーが自己の判断で使用することを前提に提供されているものであり、この回避策をお勧めするものではありません。この回避策は、自己の責任においてご使用ください。

悪意のあるユーザーや悪意のあるソフトウェアによる攻撃のリスクを抑えるには、ウイルス対策プログラムやスパイウェア対策プログラムを終了または無効にしている間、他の Web サイトにアクセスしたり、ファイルをダウンロードしたりしないでください。

インストールが失敗する最も一般的な原因の 1 つとして、Service Pack のインストーラーが必要とするファイルが、ウイルス対策プログラムなどのサードパーティ製のアプリケーションによって開いたままになっている場合や、ロックされている場合が挙げられます。この問題を回避するには、Windows XP SP3 をインストールする前に以下の手順を実行します。
  1. すべてのプログラムを終了し、コンピューターを再起動します。
  2. コンピューターを再起動した後、実行されているウイルス対策プログラムおよびスパイウェア対策プログラムをすべて終了するか、無効にします。

    : 通知領域からプログラムを無効にすることができます。これを行うには、サードパーティ製プログラムのアイコンを右クリックし、アプリケーションを閉じる、または無効にするオプションをクリックします。これらのオプションを使用できない場合は、プログラムのマニュアルを参照するか、無効にする方法をプログラムの製造元に問い合わせてください。
  3. ウイルス対策プログラムやスパイウェア対策プログラムを終了した後、方法 1 でダウンロードしたフル ダウンロード パッケージを使用して Windows XP SP3 をインストールします。
  4. Windows XP SP3 のインストールが完了した後、手順 2. で無効にしたウイルス対策プログラムやスパイウェア対策プログラムを再起動します。
この方法でエラー メッセージが解決され、Windows XP SP3 が正しくインストールされた場合、作業は完了です。

この方法で問題が解決しなかった場合で、高度なトラブルシューティングの手順に慣れている場合は、「高度なトラブルシューティング」に進みます。高度なトラブルシューティングの手順に慣れていない場合は、「次の手順」に進みます。

高度なトラブルシューティング

ここでは、「解決方法」の手順で問題が解決しなかった場合に実行する、高度なトラブルシューティングの方法について説明します。この方法は、上級レベルのユーザーを対象にしています。

方法 1: レジストリとファイルのアクセス許可をリセットする

重要: このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを変更する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。レジストリのバックアップ方法および復元方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。
322756  (http://support.microsoft.com/kb/322756/ ) Windows でレジストリをバックアップおよび復元する方法
レジストリとファイルのアクセス許可をリセットするには、以下の手順を実行します。
  1. Subinacl.exe ファイルをダウンロードし、インストールします。これを行うには、以下のマイクロソフト Web サイトを参照してください。
    http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en)
  2. メモ帳を起動します。
  3. 次のテキストをコピーしてメモ帳に貼り付けます。
    cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
    subinacl /subdirectories %windir%\*.* /grant=administrators=f /grant=system=f
    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose
    マイクロソフトは、この情報をプログラミング言語の使用方法の一例として提供するだけであり、市場性および特定目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。この資料は、例示されているプログラミング言語やプロシージャの作成およびデバッグに使用するツールについて理解されているユーザーを対象としています。Microsoft Support 担当者は、特定のプロシージャの機能についての問い合わせにはお答えできますが、ユーザー固有の目的に合わせた機能の追加、プロシージャの作成などの内容変更は行っておりません。
  4. このメモ帳のファイルを Reset.cmd という名前で保存します。
  5. Reset.cmd ファイルをダブルクリックしてサンプルを実行します。

    : このスクリプト ファイルの実行には時間がかかる場合があります。また、このスクリプトは管理者として実行する必要があります
  6. Windows XP SP3 をインストールします。
この方法でエラー メッセージが解決され、Windows XP SP3 が正しくインストールされた場合、作業は完了です。

この方法で問題が解決しない場合は、「次の手順」に進みます。

詳細

レジストリの更新が正常に行われなかったことを確認する方法

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。「%windir%\windowsupdate.log」と入力し、[OK] をクリックします。Svcpack.log ファイルが開きます。
  2. [編集] メニューの [検索] をクリックします。
  3. [検索する文字列] ボックスに「DoRegistryUpdates failed」と入力し、[次を検索] をクリックします。

    レジストリの更新に失敗している場合は、ファイル内に "DoRegistryUpdates failed" というエラー メッセージが表示されます。これは、レジストリの更新を妨げる問題が発生していることを示します。次のようなエラー メッセージが表示されます。
    xxxx.xxx: DoInstallation:DoRegistryUpdates failed.
    xxxx.xxx: アクセスが拒否されました。
    xxxx.xxx: Message displayed to the user: アクセスが拒否されました。
    : このメッセージの xxxx.xxx は、各メッセージのタイムスタンプを表します。

ウイルス対策ソフトウェア

ウイルス対策プログラムは、コンピューターをウイルスから保護するのに役立ちます。ウイルス対策プログラムが無効になっているときは、信頼できないソースからファイルをダウンロードしたり開いたりしないでください。また、信頼できない Web サイトにアクセスすること、および電子メールの添付ファイルを開くことはしないでください。コンピューター ウイルスの関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
129972  (http://support.microsoft.com/kb/129972/ ) [コンピュータ ウイルス] 解説、予防、および回復

次の手順

上記の方法で問題が解決しなかった場合、Microsoft Customer Support Services の Web サイトを使用すると問題の他の解決策を検索できます。Microsoft Customer Support Services Web サイトでは、以下のようなサービスを利用できます。
  • サポート技術情報検索 (http://support.microsoft.com/search/?adv=1) :マイクロソフト製品に関するサポート技術情報とセルフ サポート ツールを検索できます。
  • 製品別サポート ページ (http://support.microsoft.com/select/?target=hub) :よく寄せられる質問と重要なサポート情報を製品別に参照できます。
  • マイクロソフト ニュースグループ (http://www.microsoft.com/japan/communities/newsgroups/default.mspx) :他のユーザーやマイクロソフト MVP (Most Valuable Professionals) から情報を得ることができます。
  • その他のサポート オプション (http://support.microsoft.com/default.aspx?pr=csshome) :Web を使用した質問、Microsoft Customer Support Services への問い合わせ、フィードバックの送信を行うことができます。
問題が継続する場合は、次のページからサポートに問い合わせることもできます。
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Service Pack 3
  • Microsoft Windows XP Service Pack 2
キーワード: 
kbexpertisebeginner kbregistry kberrmsg kbtshoot kbprb KB949377
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