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文書番号: 835973 - 最終更新日: 2006年12月14日 - リビジョン: 2.0

Windows Messenger 5.0 のインストール後、Windows が応答を停止し、Csrss.exe プロセスの CPU 使用率が 100% になる

目次

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現象

Microsoft Windows Messenger 5.0 のインストール後、以下のすべての現象が発生することがあります。
  • Windows の動作が非常に遅くなるか、Windows が応答を停止 (ハング) します。
  • Windows のタスク マネージャの [プロセス] タブを参照すると、Csrss.exe プロセスの CPU 使用率が 100%、メモリ使用量が約 200 MB と表示されます。
  • Msmsgs.exe プロセスを終了するか、Windows を再起動すると、この問題は一時的に解決します。
  • Windows または Windows Messenger を再起動した後、14 日間以上これらを再起動しないと、この問題が再発します。

原因

この問題は、Windows Messenger の Service Quality Monitor (SQM) データ収集のタイマ機能の不具合によって発生します。SQM データ収集に関する新しいタイマが開始しても、以前のタイマが終了しません。約 14 日後には、約 32,000 のタイマが作成されます。これにより、Windows の CPU 使用率とメモリ使用量が増加します。

解決方法

この問題を解決するには、Windows Messenger の最新版をダウンロードしてインストールします。Windows Messenger の最新版を入手するには、次のマイクロソフト Web サイトにアクセスしてください。
http://www.microsoft.com/downloads/details.aspx?FamilyID=a8d9eb73-5f8c-4b9a-940f-9157a3b3d774&DisplayLang=ja (http://www.microsoft.com/downloads/details.aspx?FamilyID=a8d9eb73-5f8c-4b9a-940f-9157a3b3d774&DisplayLang=ja)

回避策

この問題を回避するには、次のいずれかの方法を使用します。

方法 1 : Windows Messenger を再起動する

14 日ごとに次のいずれかの操作を行います。
  • Windows Messenger を再起動します。
  • Windows を再起動します。

方法 2 : Windows Messenger を無効にする

Windows Messenger を使用しない場合は、Windows の起動時に Windows Messenger が自動的に起動しないように構成します。これを行うには、次の手順を実行します。
  1. タスク バーの通知領域にある Windows Messenger のアイコンを右クリックし、[開く] をクリックします。
  2. [ツール] メニューの [オプション] をクリックします。
  3. [設定] タブをクリックし、[Windows の起動時に Windows Messenger を実行する] チェック ボックスをオフにし、[OK] をクリックします。
  4. [ファイル] メニューの [閉じる] をクリックします。
  5. タスク バーの通知領域にある Windows Messenger のアイコンを右クリックし、[終了] をクリックします。

状況

マイクロソフトでは、この問題を Microsoft Windows Messenger 5.0 の問題として認識しています。 この問題は Microsoft Windows Messenger 5.0.0482 で修正済みです。

この資料は以下の製品について記述したものです。
  • Microsoft Office Live Communications Server 2003
  • Microsoft Windows Messenger 5.0
キーワード: 
kbfix kbbug KB835973
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