サポート オンライン

Windows XP の RTC クライアントによる NAT のサポートについて

文書番号:316397
最終更新日:2006年3月24日
リビジョン:2.2
この記事は、以前は次の ID で公開されていました: JP316397

現象

クライアントが NAT (Network Address Translation) デバイスの内側に配置されている場合、リアルタイム コミュニケーション (RTC) クライアントを使用する通信が行えません。この資料に記載されている修正プログラムを適用することにより、オーディオまたはビデオ ストリームのセットアップ時に、NAT を使用するプログラムから RTC API を経由して正常なアドレスおよびポートを使用するようになります。この修正プログラムのインストール後、NAT デバイスの内側に配置されているクライアントは、NAT デバイスの外側に配置されている他のクライアントまたはゲートウェイとのオーディオおよびビデオ通信を行えるようになります。この修正プログラムを適用しても、NAT デバイスの内側に配置されているクライアントから SIP (Session Initiation Protocol) サーバーへの接続は行えず、NAT デバイスの内側に配置されている Microsoft Windows Messenger クライアント間でオーディオおよびビデオを相互に使用することもできません。ただし、この修正プログラムを適用することにより、NAT デバイスの内側に配置されている Windows Messenger クライアントと音声ゲートウェイとの通信が行えるようになります。

先頭へ戻る

原因

本来は、RTC クライアントで、NAT デバイスの内側での通信はサポートされていませんでした。

先頭へ戻る

解決方法

この問題を解決するには、Windows XP の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322389 (http://support.microsoft.com/kb/322389/) 最新の Windows XP Service Pack を入手する方法
下記のファイルは、「Microsoft ダウンロード センター」からダウンロードできます。
ダウンロードQ316397_wxp_sp1_x86_JPN.exe (http://www.microsoft.com/Downloads/details.aspx?displaylang=ja&FamilyID=2C35AA44-CD9F-4424-922A-8E98BC1A0A2C)
リリース日 : 2002 年 2 月 25 日

マイクロソフトのサポート ファイルのダウンロード方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
119591 (http://support.microsoft.com/kb/119591/) オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトでは、アップロード時点の最新のウイルス検査プログラムを使用して、配布ファイルのウイルス チェックを行っています。配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。 修正プログラム (日本語版) の属性は次のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。
   日付           時刻    バージョン         サイズ     ファイル名
   ------------------------------------------------------
   2001/10/12  14:10  5.1.2601.0       139,264  aec.sys         
   2001/12/11  16:43  5.1.2600.16      844,288  dxmrtp.dll      
   2002/02/10  10:51  5.1.2600.28      549,888  rtcdll.dll      
   2001/10/12  14:22  5.1.2600.16        6,016  splitter.sys    
   2001/11/27  14:20  5.1.2600.21       56,832  usbaudio.sys    
   2002/01/30  18:07  5.1.2600.28       19,200  usbuhci.sys     

				

先頭へ戻る

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。 この問題は、Windows XP Service Pack 1 で修正済みです。

先頭へ戻る

詳細

RTC クライアント API (アプリケーション プログラミング インターフェイス) は、Windows XP の新機能です。この機能は、インスタント メッセージングおよびビデオ会議ソフトウェアなどのリアルタイム プログラムの迅速な開発を容易にするよう設計されています。

SIP (Session Initiation Protocol) は、新しく登場したインターネット標準であり、メッセージング、プレゼンス、マルチメディア会議、およびテレフォニーなどのリアルタイム コミュニケーションを柔軟に統合します。SIP は革新的な方法でプログラムを統合するモジュールとして設計されており、拡張によって新しい技術をサポートします。

先頭へ戻る

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 316397 (http://support.microsoft.com/kb/316397/EN-US/) (最終更新日 2003-11-04) を基に作成したものです。

先頭へ戻る


この資料は以下の製品について記述したものです。
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional

先頭へ戻る

キーワード: 
kbhotfixserver kbenv kbbug kbfix kbnetwork kbwinxpsp1fix KB316397

先頭へ戻る

"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

製品別 サポート ページ

その他のサポート オプション

  • 製品別 お問い合わせ
    電話や電子メールでマイクロソフトへ問い合わせる。
  • カスタマー インフォメーション センター
    製品の購入やプライバシーなどに関する情報など、技術情報以外のお問い合わせ窓口です。
  • マイクロソフト コミュニティ
    マイクロソフト製品や関連技術に関する知識とニュースを共有することを目的に、ユーザーの皆様、各分野のエキスパートなどの間で情報交換する場です。
  • KB ご利用の際のご注意
    お使いの Windows 環境によっては、"\" (バックスラッシュ) は "¥" (円記号) と表示される場合があります。

ページ ツール