サポート情報 : トレンドマイクロ

ウイルスパターンファイル2.594.00(日本時間:午前7:33頃公開)へのアップデートにおける、コンピュータのCPUが100%になる現象に関して
[掲載日:2005年4月23日 13:40]
[最終更新日:2005年6月15日 20:58]

更新履歴
2005年06月15日 20:58:「復旧費用ご相談窓口」の受付終了に伴い、窓口の表記を削除しました
2005年06月03日 11:58:「パターンファイル594ファイル削除CD-ROMの受付」終了に伴い、窓口の表記を削除しました
2005年05月06日 20:00 : 「対応方法」における「ServerProtectの手順」記述を「ServerProtect for WindowsNTの手順」に変更しました。
2005年04月27日 12:14 : 「ウイルスパターンファイルに関する問題」への対応について、問合せ先に追記しました。
2005年04月26日 22:52 : 2005年4月26日 記者会見の場で発表した最新の情報に基づき情報を更新いたしました。
それ以前の更新履歴につきましてはこちらをご確認ください。

※現在電話問い合わせにおいて、間違い電話が多くなっております。
お問い合わせの際は番号をお確かめの上ご連絡ください。(4月25日19時)

本件はウイルスパターンファイル2.594.00に原因があり、ウイルスバスター等の製品そのものの問題ではございません。また、平成17年4月23日午前10:51に公開されたウイルスパターンファイル2.596.00及びそれ以降のウイルスパターンファイルにつきましては、本問題は発生いたしません。

■概要

2005年 4月23日 午前7:33から同日午前9:02の間に公開されていたウイルスパターンファイル2.594.00を弊社製品にアップデートした直後から、コンピュータの動作が著しく遅くなり、通常の運用が困難となる事象が発生する場合があることが判明しました。
お客様には大変ご迷惑をおかけしましたことを深くおわび申し上げます。
つきましては、お客様におかけするご迷惑を最小限にすべく、不具合個所を修正したパターンファイル2.596.00をトレンドマイクロホームページ上に公開し、24時間体制のサポート窓口の設置、FAXBOXの設置、e-mailによるご連絡等を通じて対応させていただきます。
今後、このようなことがないよう品質向上・管理に一層の努力を重ねて参ります。


■発生環境

  • 検索エンジン 7.51および、7.50を使用

    かつ

  • ウイルスパターンファイル 2.594.00を使用


■発生状況

  1. 発生条件
    この問題は、検索エンジン7.51もしくは、7.50を搭載したコンピュータでウイルスパターンファイル2.594.00を使用した場合に発生条件を満たすファイルの検索を行うことで発生します。

    該当パターンのダウンロード数は現在のところ、約17万件程度と推定しています。
    ※お客様のシステム環境により、多少時刻に前後がございますのでご了承ください。

  2. 発生条件を満たすファイル
    次の2つの条件を満たすファイルが発生環境において検索がされた場合に発生します。
    • エントリポイント番地の指定がない

      かつ

    • 1セクションにより構成される

      ※このような特徴をもつファイルは一部のソフトウェアに含まれています。

  3. 現象
    特定のファイル判定ミスにより、ファイルのウイルス検索が繰り返され、CPU使用率が100%に近い状態となり、コンピュータの動作が著しく遅くなる

  4. 原因
    1. ウイルスパターンファイルの「圧縮判定」パターンに問題がありました
      発生条件を満たすファイルを検索する際に、以下の機能が問題を起こしていました。
      • 検索エンジン7.50、および7.51にはWORM_RBOTの検出を高めるために「Ultra Protect圧縮」を判定、解凍する機能が追加されました。

      • パターンファイル内の「Ultra Protect圧縮」を判定、解凍する情報に誤りがあったために、特定条件のファイル(エントリーポイント番地の指定がなく、かつ1セクションにより構成されるファイル)を誤った判定の元、検索を繰り返してしまうことでコンピュータの動作が著しく遅くなります。

    2. パターンファイル公開前テスト時の二重の人為的ミスがありました
      • さまざまな環境でのパターン品質チェックの中で、Microsoft Windows XP Service Pack 2環境でのテストが今回のみ実施されませんでした。
      • 「Ultra Protect圧縮」機能対応前の検索エンジン7.00を使用してテストを実施してしまったため、圧縮判定、解凍の動作の検査が実施されませんでした。

  5. 対策
    パターンファイルの作成、テスト工程におけるダブルチェック体制の徹底、チェックプロセスの自動化、テスト工程とテストファイルの見直しおよび追加、業務にて稼動しているさまざまなOSに対する製品を用いたテストの強化を行ってまいります。

  6. 今回の問題の影響範囲
    本問題修正済みのウイルスパターンファイル2.596.00は、2005年4月23日午前10:51に公開しています。2005年4月23日午前7:33から午前9:02の間に該当パターンをアップデートしなかったお客様は、本問題は発生しません。
    また、これから新たにトレンドマイクロ製品を導入されるお客様においても、本問題は発生しません。


■環境に応じた発生率

本件に関しましてはウイルスパターンファイル2.594.00に問題があり、ウイルスバスター等の製品そのものの問題ではございません。このため発生環境において発生条件を満たすファイルがより多く含まれる環境において発生率が高くなります。

  1. 発生条件を満たすファイルを含み、問題発生率が高い環境
    • Microsoft Windows XP Service Pack 2
    • Microsoft Windows Server 2003
    • Microsoft Windows Server 2003 Service Pack 1
      ※上記OSがログオン時などに使用するダイナミック リンク ライブラリ (DLL)の一部が発生条件を満たすファイルとなります。このため、これらのOSの場合には、問題の発生率が非常に高くなります。
  2. 発生条件を満たすファイルを含むが、問題発生率が比較的低い環境
    • Microsoft Windows Me
    • Microsoft Office XP
      ※上記ソフトウェアに含まれる発生条件を満たすファイルは、ソフトウェアによる使用頻度の低いファイルです。このため、これらのソフトウェアの場合には、問題の発生率が比較的低くなります。

    上記以外にも、発生条件を満たすファイルをウイルス検索した場合に同様の問題が発生する可能性があります。

■問題判別ナビゲーション

■対応方法

ウイルスパターンファイル 2.596.00(日本時間:午前10:51頃公開)にて問題を修正しております。
ウイルスパターンファイル 2.596.00以降へアップデートできている環境においては、本問題は発生いたしません。

既に、問題が発生している環境においては、以下の方法にて対応をお願いいたします。

以下の手順で、修正済みのウイルスパターンファイル 2.596.00 以降を適用してください。


本現象の回避を支援する「トレンドマイクロ パターンファイル問題修復ツール(TMRMTool.exe)」を公開させていただきます。このツールを使用することで本現象が回避されるようになります。
「トレンドマイクロ パターンファイル問題修復ツール(TMRMTool.exe)」公開のお知らせ

■問い合わせ先:

0

※間違い電話が多くなっております。お問い合わせの際は番号をお確かめの上ご連絡ください。

●トレンドマイクロ緊急対応窓口(法人のお客様、個人のお客様共通)
「トレンドマイクロ緊急対応窓口」および「ウイルスバスタークラブセンター」の24時間対応は2005年5月8日24:00をもちまして終了しました。

●個人のお客様の電話によるお問い合わせ

ウイルスバスターに関するお問い合わせ(技術的なお問い合わせ、登録に関するお問い合わせ)
0
ご連絡窓口 ウイルスバスタークラブセンターにお問い合わせください
受付時間 9:30〜17:30
(土曜、日曜、祝祭日およびその振替日を除きます)
0

復旧費用ご相談窓口の受付は、2005年 6月15日(水) 20:00をもちまして終了しました。
 
パターンファイル594ファイル削除CD-ROMの受付は、2005年 5月31日(火) 17:30をもちまして終了しました。


●法人のお客様の電話によるお問い合わせ

本問題に関する技術的ご質問・お問い合わせ
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ご連絡窓口 トレンドマイクロサポートセンター
受付時間 9:00〜12:00/13:00〜17:30
(土曜、日曜、年末年始、祝祭日およびその振替日を除きます)
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0 電話番号およびFAX番号は製品付属のマニュアルにてご確認ください。
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0 お問い合わせの際には、お手元にシリアル番号をご用意の上、ご連絡ください。
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